import re
regex = re.compile(r"\/p\/(?:.*\/)?(\d+)\b")
test_str = ("http://www.example.com/p/12345678\n"
"http://www.example.com/p/12345678?foo=bar\n"
"http://www.example.com/p/some-text-123/1234567890?foo=bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")