re = /\/p\/(?:.*\/)?(\d+)\b/
str = 'http://www.example.com/p/12345678
http://www.example.com/p/12345678?foo=bar
http://www.example.com/p/some-text-123/1234567890?foo=bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end