package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.+\slimit\s\d{1,},\d{1,3}$`)
var str = `select * from issue limit 0,100`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}