const regex = /^.+\slimit\s\d{1,},\d{1,3}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+\\slimit\\s\\d{1,},\\d{1,3}$', '')
const str = `select * from issue limit 0,100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}