# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/span
:[^)]*[)];?//g;t' <<< "<span style=\"background-image: url (\"http://mantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png\"); bgcolor:'red'\">11111<br />
<span style=\"background-image: url('https:// asd asdmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">22222
<span style=\"background-image:url('https://fmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">3333
<span style=\"background-image:url( 'https://fmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">444
<span style=\"background-image: url ( \"http://mantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png\");\">555<br />
<span style=\"background-image: url(xx https://trk.workexpert.net/web/include/ckeditor_432/plugins/icons.png?t=E0LB& xx); >666"