import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "span\n"
+ ":[^)]*[)];?";
final String string = "<span style=\"background-image: url (\"http://mantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png\"); bgcolor:'red'\">11111<br />\n"
+ "<span style=\"background-image: url('https:// asd asdmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">22222\n"
+ "<span style=\"background-image:url('https://fmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">3333\n"
+ "<span style=\"background-image:url( 'https://fmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">444\n"
+ "<span style=\"background-image: url ( \"http://mantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png\");\">555<br />\n"
+ "<span style=\"background-image: url(xx https://trk.workexpert.net/web/include/ckeditor_432/plugins/icons.png?t=E0LB& xx); >666";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}