import re
regex = re.compile((r"span\n"
r":[^)]*[)];?"))
test_str = ("<span style=\"background-image: url (\"http://mantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png\"); bgcolor:'red'\">11111<br />\n"
"<span style=\"background-image: url('https:// asd asdmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">22222\n"
"<span style=\"background-image:url('https://fmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">3333\n"
"<span style=\"background-image:url( 'https://fmantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png')\">444\n"
"<span style=\"background-image: url ( \"http://mantis.we.intern/custom/userfiles/image/6y0eC4vzptnIxsikHs0AJA.png\");\">555<br />\n"
"<span style=\"background-image: url(xx https://trk.workexpert.net/web/include/ckeditor_432/plugins/icons.png?t=E0LB& xx); >666")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)