using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(\.\d+)?(?:[ -]\d+\/\d+)?'(?!')";
string input = @"5'6''
5'6""
6'
3 1/2'
12.5'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}