re = /\d+(\.\d+)?(?:[ -]\d+\/\d+)?'(?!')/
str = '5\'6\'\'
5\'6"
6\'
3 1/2\'
12.5\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end