$re = '/\d+(\.\d+)?(?:[ -]\d+\/\d+)?\'(?!\')/';
$str = '5\'6\'\'
5\'6"
6\'
3 1/2\'
12.5\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);