# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?![0-9.,!?:;_|+\-*\\/=%°@&#§$\"'`¨^ˇ()\[\]<>{}])[\S])+$"
test_str = ("Vit5\n"
"V.it\n"
".Vit\n"
"Vit.\n"
"Vit\\\\\n"
"V|it\n"
"Vi-t\n"
"V+it\n"
"+Vit\n"
"Vit^\n"
"V^it\n"
"V&it\n"
"Vi#t\n"
"Vi@t\n"
"Vit \n"
" Vit\n"
"V it\n"
"Vi)t\n"
"V(it\n"
"Vi[t\n"
"Vi]t\n"
"V?it\n"
"V!it\n"
"V$it\n"
"V*it\n"
"Vi{t\n"
"Vi}t\n"
"V<it\n"
"Vi>t\n"
"Vi_t\n"
"V-it\n"
"Vi=t\n"
"Vi%t\n"
"ˇVit\n"
"V;it\n"
"V\\\"it\n"
"V'it\n"
"V§t\n"
"V¨t\n"
"V`t\n\n"
"Dopita\n"
"Václav\n"
"Átos\n"
"Čeněk\n"
"Pačáp\n"
"Ďurica\n"
"Naďa\n"
"Rémi\n"
"Zdeněk\n"
"Vít\n"
"Ľudovít\n"
"Ňouma\n"
"Ňuňu\n"
"Lórenc\n"
"Ópava\n"
"Mótovidlo\n"
"Řeřicha\n"
"Šušinka\n"
"Ťaťak\n"
"Úlehlú\n"
"Ůlehlů\n"
"Ýtý\n"
"Žežulka")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.