import Foundation
let pattern = ##"^((?![0-9.,!?:;_|+\-*\\/=%°@&#§$"'`¨^ˇ()\[\]<>{}])[\S])+$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Vit5
V.it
.Vit
Vit.
Vit\\
V|it
Vi-t
V+it
+Vit
Vit^
V^it
V&it
Vi#t
Vi@t
Vit
Vit
V it
Vi)t
V(it
Vi[t
Vi]t
V?it
V!it
V$it
V*it
Vi{t
Vi}t
V<it
Vi>t
Vi_t
V-it
Vi=t
Vi%t
ˇVit
V;it
V\"it
V'it
V§t
V¨t
V`t
Dopita
Václav
Átos
Čeněk
Pačáp
Ďurica
Naďa
Rémi
Zdeněk
Vít
Ľudovít
Ňouma
Ňuňu
Lórenc
Ópava
Mótovidlo
Řeřicha
Šušinka
Ťaťak
Úlehlú
Ůlehlů
Ýtý
Žežulka
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)