re = /^((?![0-9.,!?:;_|+\-*\\\/=%°@&#§$"'`¨^ˇ()\[\]<>{}])[\S])+$/m
str = 'Vit5
V.it
.Vit
Vit.
Vit\\\\
V|it
Vi-t
V+it
+Vit
Vit^
V^it
V&it
Vi#t
Vi@t
Vit
Vit
V it
Vi)t
V(it
Vi[t
Vi]t
V?it
V!it
V$it
V*it
Vi{t
Vi}t
V<it
Vi>t
Vi_t
V-it
Vi=t
Vi%t
ˇVit
V;it
V\\"it
V\'it
V§t
V¨t
V`t
Dopita
Václav
Átos
Čeněk
Pačáp
Ďurica
Naďa
Rémi
Zdeněk
Vít
Ľudovít
Ňouma
Ňuňu
Lórenc
Ópava
Mótovidlo
Řeřicha
Šušinka
Ťaťak
Úlehlú
Ůlehlů
Ýtý
Žežulka'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end