using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"the(\s+\S+\s+)red dog";
string input = @"If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}