const regex = /the(\s+\S+\s+)red dog/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('the(\\s+\\S+\\s+)red dog', 'gm')
const str = `If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}