$re = '/the(\s+\S+\s+)red dog/m';
$str = 'If the quick brown dog jumps over the lazy red dog, then the crazy red dog will run past the lazy red dog.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);