using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)\p{L}++(?!\p{P}\S)";
string input = @"Hello, I am kjd#(@*#@m, aa.aa.aa.aa. It was nice meeting you.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}