re = /(?<!\S)\p{L}++(?!\p{P}\S)/
str = 'Hello, I am kjd#(@*#@m, aa.aa.aa.aa. It was nice meeting you.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end