$re = '/(?<!\S)\p{L}++(?!\p{P}\S)/';
$str = 'Hello, I am kjd#(@*#@m, aa.aa.aa.aa. It was nice meeting you.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);