#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\btranslate\(\s*\K'(?:[^'\\]*)(?:\\.[^'\\]*)*'"
Local $sString = "translate('hello world', true, 1, 'foobar', 'etc');" & @CRLF & _
"translate('hello\'s world');" & @CRLF & _
"translate('hello \'world\', you\'re great!');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")