import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\btranslate\\(\\s*\\K'(?:[^'\\\\]*)(?:\\\\.[^'\\\\]*)*'";
final String string = "translate('hello world', true, 1, 'foobar', 'etc');\n"
+ "translate('hello\\'s world');\n"
+ "translate('hello \\'world\\', you\\'re great!');";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}