$re = '/\btranslate\(\s*\K\'(?:[^\'\\\\]*)(?:\\\\.[^\'\\\\]*)*\'/';
$str = 'translate(\'hello world\', true, 1, \'foobar\', \'etc\');
translate(\'hello\\\'s world\');
translate(\'hello \\\'world\\\', you\\\'re great!\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);