const regex = /\/([^\/]+?)_/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/([^\\\/]+?)_', 'gu')
const str = `/Users/username/Documents/TEST/Move to SubFolder/S010A03_Test_File path.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}