re = /\/([^\/]+?)_/
str = '/Users/username/Documents/TEST/Move to SubFolder/S010A03_Test_File path.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end