$re = '/\/([^\/]+?)_/u';
$str = '/Users/username/Documents/TEST/Move to SubFolder/S010A03_Test_File path.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);