# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^\s*[[:upper:]][[:alpha:]]*|.*?([[:upper:]][[:alpha:]]*|$)/\n/gm;t' <<< "Words of sentences (that are preceeded by a Space and a Period), and also ignoring the first word of the cell
How to extract Words with Uppercase first letter only
With"