using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^\s*[[:upper:]][[:alpha:]]*|.*?([[:upper:]][[:alpha:]]*|$)";
string substitution = @"\n";
string input = @"Words of sentences (that are preceeded by a Space and a Period), and also ignoring the first word of the cell
How to extract Words with Uppercase first letter only
With";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}