use strict;
my $str = 'Words of sentences (that are preceeded by a Space and a Period), and also ignoring the first word of the cell
How to extract Words with Uppercase first letter only
With';
my $regex = qr`(?m)^\s*[[:upper:]][[:alpha:]]*|.*?([[:upper:]][[:alpha:]]*|$)`mp;
my $subst = '\\n';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";