using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/(([-\w\.]+)+(:\d+)?(\/([-\w/_\.]*(\?\S+)?)?)?))";
string input = @"http://www.sdfcsdf.com/ss-sdf/";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}