re = /(https?:\/\/(([-\w\.]+)+(:\d+)?(\/([-\w\/_\.]*(\?\S+)?)?)?))/i
str = 'http://www.sdfcsdf.com/ss-sdf/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end