$re = '/(https?:\/\/(([-\w\.]+)+(:\d+)?(\/([-\w/_\.]*(\?\S+)?)?)?))/i';
$str = 'http://www.sdfcsdf.com/ss-sdf/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);