$re = '/(?<=\/|\\\\|v|\\\\\/)(\d.+\d.+\d+[a-zA-Z0-9-]*)$/m';
$str = 'https://github.com/artifex404/grav-plugin-instgram/zipball/v1.1.0
https://github.com/artifex404/grav-plugin-instgram/zipball/1.1.0
https://github.com/artifex404/grav-plugin-instgram/zipball\\1.1.0-rc1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);