import Foundation
let pattern = #"(?<=\/|\\|v|\\\/)(\d.+\d.+\d+[a-zA-Z0-9-]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://github.com/artifex404/grav-plugin-instgram/zipball/v1.1.0
https://github.com/artifex404/grav-plugin-instgram/zipball/1.1.0
https://github.com/artifex404/grav-plugin-instgram/zipball\1.1.0-rc1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)