re = /(?<=\/|\\|v|\\\/)(\d.+\d.+\d+[a-zA-Z0-9-]*)$/m
str = 'https://github.com/artifex404/grav-plugin-instgram/zipball/v1.1.0
https://github.com/artifex404/grav-plugin-instgram/zipball/1.1.0
https://github.com/artifex404/grav-plugin-instgram/zipball\\1.1.0-rc1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end