const regex = /(
.*
\b(why|what)\b
.*
\?
){2,}/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(
.*
\\b(why|what)\\b
.*
\\?
){2,}', 'ig')
const str = `
1) What I love u? Look at me. Why I love u?
3) Why do you look at me?
4) Are you alright?
5) I am sick. How are you?. Well you do not have to answer it. what's up?
6) How are you? I am sick. What's up? Well you do not have to answer it.
7) Why I love u?
8) Any questions? No. Why not? Sure? Ok?
9) Jesus christ. You know what, do I love u? Look at me! Why I love u?
10) what do you want? what do you mean?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}