re = /(
.*
\b(why|what)\b
.*
\?
){2,}/ix
str = '
1) What I love u? Look at me. Why I love u?
3) Why do you look at me?
4) Are you alright?
5) I am sick. How are you?. Well you do not have to answer it. what\'s up?
6) How are you? I am sick. What\'s up? Well you do not have to answer it.
7) Why I love u?
8) Any questions? No. Why not? Sure? Ok?
9) Jesus christ. You know what, do I love u? Look at me! Why I love u?
10) what do you want? what do you mean?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end