# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(
.*
\b(why|what)\b
.*
\?
){2,}
"""
test_str = ("\n"
"1) What I love u? Look at me. Why I love u?\n"
"3) Why do you look at me?\n"
"4) Are you alright?\n"
"5) I am sick. How are you?. Well you do not have to answer it. what's up?\n"
"6) How are you? I am sick. What's up? Well you do not have to answer it. \n"
"7) Why I love u?\n"
"8) Any questions? No. Why not? Sure? Ok?\n"
"9) Jesus christ. You know what, do I love u? Look at me! Why I love u?\n"
"10) what do you want? what do you mean?\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.