const regex = /^[.,?!'"\s]+|[.,?!'"\s]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[.,?!\'"\\s]+|[.,?!\'"\\s]+$', 'gm')
const str = `'Hello world, josh's car.,'
Hello World.......
..,!Bye World
.???'"""Again, what message should I type here!!!
..,!Spaces `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);