re = /^[.,?!'"\s]+|[.,?!'"\s]+$/m
str = '\'Hello world, josh\'s car.,\'
Hello World.......
..,!Bye World
.???\'"""Again, what message should I type here!!!
..,!Spaces '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result