import re
regex = re.compile(r"^[.,?!'\"\s]+|[.,?!'\"\s]+$", flags=re.MULTILINE)
test_str = ("'Hello world, josh's car.,'\n\n"
"Hello World.......\n"
"..,!Bye World\n\n"
".???'\"\"\"Again, what message should I type here!!!\n\n\n"
" ..,!Spaces ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)