using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{0,25}$)[+#]?\d*(?:X*|\*?)$";
string input = @"The regex should match any given number:
012345
+12345
#1234525
But also match for strings with a X in it.
12345X
12345XX
1234XXXXXX
XXXXXX
also
12345*
Not allowed
1234*X
1234X*
1234**
1234X*
12345*X
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}