$re = '/^(?=.{0,25}$)[+#]?\d*(?:X*|\*?)$/m';
$str = 'The regex should match any given number:
012345
+12345
#1234525
But also match for strings with a X in it.
12345X
12345XX
1234XXXXXX
XXXXXX
also
12345*
Not allowed
1234*X
1234X*
1234**
1234X*
12345*X
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);