# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.{0,25}$)[+#]?\d*(?:X*|\*?)$"
test_str = ("The regex should match any given number:\n\n"
"012345\n"
"+12345\n"
"#1234525\n"
"But also match for strings with a X in it.\n\n"
"12345X\n"
"12345XX\n"
"1234XXXXXX\n"
"XXXXXX\n\n"
"also\n"
"12345*\n\n"
"Not allowed\n"
"1234*X\n"
"1234X*\n"
"1234**\n"
"1234X*\n"
"12345*X\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.