package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^\/en\/category).*(-\d{1,4}$)`)
var str = `/en/category/specials/men-2610`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}