const regex = new RegExp('(?:^\\/en\\/category).*(-\\d{1,4}$)', '')
const str = `/en/category/specials/men-2610`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}