$re = '/(?:^\/en\/category).*(-\d{1,4}$)/';
$str = '/en/category/specials/men-2610';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);