import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *((\\/+.*\\n*.*)|(\\[.*\\]\\n*.*))*public [A-Za-z\\_\\?\\<\\>]* ([A-Za-z0-9\\_]*) .*(\\n| )*";
final String string = "[DatabaseGenerated(DatabaseGeneratedOption.None)]\n"
+ " public long Id { get; set; }\n\n"
+ " [Required]\n"
+ " [StringLength(15)]\n"
+ " public string Email { get; set; }\n"
+ " public string CellPhone { get; set; }\n"
+ " public int NumChildren { get; set; }\n"
+ " public DateTime BirthDate { get; set; }\n"
+ " /// <summary>\n"
+ " /// Base64\n"
+ " /// </summary>\n"
+ " public string Image { get; set; }\n\n\n"
+ " public List<FullSdnOption> Optionen { get; set; }";
final String subst = "$4 = person.$4,\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}