const regex = / *((\/+.*\n*.*)|(\[.*\]\n*.*))*public [A-Za-z\_\?\<\>]* ([A-Za-z0-9\_]*) .*(\n| )*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' *((\\\/+.*\\n*.*)|(\\[.*\\]\\n*.*))*public [A-Za-z\\_\\?\\<\\>]* ([A-Za-z0-9\\_]*) .*(\\n| )*', 'gim')
const str = `[DatabaseGenerated(DatabaseGeneratedOption.None)]
public long Id { get; set; }
[Required]
[StringLength(15)]
public string Email { get; set; }
public string CellPhone { get; set; }
public int NumChildren { get; set; }
public DateTime BirthDate { get; set; }
/// <summary>
/// Base64
/// </summary>
public string Image { get; set; }
public List<FullSdnOption> Optionen { get; set; }`;
const subst = `$4 = person.$4,\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);