using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+|\""[\w\s]+\"")";
string input = @"'sdkflkds sdfsdf ""slkdfjsldkjf sdfskdjhk"" dgdlkfgdlkj dflkgjhdfkljh ""dfgkjdhgkjdh dsfkjdksjfhsdkjf"" dfglkdjfgl'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}