package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w]+|\"[\w\s]+\")`)
var str = `'sdkflkds sdfsdf "slkdfjsldkjf sdfskdjhk" dgdlkfgdlkj dflkgjhdfkljh "dfgkjdhgkjdh dsfkjdksjfhsdkjf" dfglkdjfgl'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}